Crossover 30Q5 Pro Black 30″ 2560 x 1600 Korean IPS Monitor Repair Notes

 

 

 

Crossover 30Q5 Pro Black 30″ 2560×1600 IPS Korean Monitor Repair Notes

Front MINE

(Photo from eBay listing)

After finding then winning a faulty Crossover 30Q5 Pro Black 30″ for £5 I wanted to start checking for known faults. In case you’ve not come across similar monitors before they are sold on eBay from Korea. They are designed for Korean internet gaming cafes and as such are fairly low tech apart from the nice panel. The only controls are a power button and a pair of buttons for backlight adjustment. Usually just the one (native) resolution; no speakers, no scaler and dual-link DVI only, no HDMI, DP, VGA, etc. There are versions with all that stuff but they cost a fair bit more. The panels are the same as used in the Apple 30″ Cinema display and some Dell and HP monitors. The 27″ 2560×1440 versions are more popular due to price. The 30″ is between £450 – £600 depending on options and ‘Perfect Pixel’ status. Apple 30″ is £1100 for the same thing…

Preparations

These Korean monitors including the 27″ 2560×1440 ones all need a Dual Link DVI cable. Just in case there wasn’t one with the monitor I ordered one from Amazon, £7 inc P&P. Very good quality but I did beep out the pins just to save my sanity. I nearly went mad whilst trouble shooting years ago due to 3 ‘known good’ serial cables being actually not so good. Check EVERYTHING, assume NOTHING.

Before I started on the good stuff I had to organise power. These Korean monitors come with external 24V DC PSUs, usually about 7A. This one didn’t although to be fair the listing didn’t mention one; I just assumed it was included. I have several 24V PSUs, DIN rail mount, linear etc. None had enough current, and also didn’t have the 4 pin mini DIN type power plug the monitor expects.

24V 7A PSU Case Label INC PINOUT

Another complication is the different pinouts the PSUs can have. Because I couldn’t be arsed to wait around for a few days and double the cost of the monitor by ordering a connector I got an old blanket for scratch protection and gently laid the screen face down on the healing bench.

Getting in was a pleasant surprise, all standard crossheads that came out easily with a PH2 screwdriver.  Despite looking plastic in the photo the case is actually steel of a decent gauge, I was quite impressed.

Back MINE

I decided to desolder the power socket and hard wire something convenient to its PCB holes.

It was a pig of a job. Large ground and power planes soak up heat very well and there are some tiny SMD bits nearby so using my large 150W iron was out.  I’ve got a generic temp controlled soldering ‘station’ thats about 10 years old, 48W maybe? Anyhow that just about managed to get the solder hot enough after I used liberal amounts of flux and added good old leaded solder to the joints to aid heat transfer and help bring the mixture’s melting point down a bit. It came out, but one of the legs pulled the plating out of its hole. There are 4 power pins and 5 connector shell legs. The shell legs are the hardest as in addition to the ground plane theres also the whole connector shell radiating heat away from the solder joint.

Interestingly there was a PCB design feature next to the power connector that I’d not come across before. Its marked with a red rectangle in the photo.

DigitalWave DW270QDP LVDS Board PSU PINOUT MARKED

DigitalWave DW270QDP MP REV.02 DVI to LVDS Board

Its a routing matrix for different power plug pinouts, it can cope with any combination of + or – on any of the power pins by populating the correct 0R link resistors. Its an elegant solution although I’m not sure about stuffing 7A through 2 0805 resistors in parallel, even if they are 0 ohm. Its a double sided PCB with hidden vias and all that jazz and I really couldn’t be arsed to reverse engineer it. I knew what the pinout was after a bit of continuity testing but the power socket footprint was multi purpose and had a lot of different slots milled out; looked mechanically weak.

On principle I wanted to replace the main cap just to the left of the socket, it was a no name brand and had a fair bit of current rippling across it.

24V 7A PSU Top

Heres the guts of it’s proper PSU, found the photo on the net. Cost optimised to within an inch of its life. Cheap filter caps in an enclosed space = heat & dirty DC output + (very) early failure.

After desoldering the cap (highish ESR, value 30% down) I soldered in a section of solid copper mains cable (!) with coloured heatshrink for polarity. I left enough bare copper above the PCB  to allow piggybacking the replacement cap. The piggyback cap in the photos was replaced with a Panasonic as soon as I knew I’d got it working. Although the temporary replacement in the photo is a dodgy looking type it actually had very low ESR and the value was within 5%.

New Power

New Power TOP

 

New Power SIDE with cap II

New Power TOP with cap

New Power BOTTOM with cap

Power

Eventually I’ll source a nice compact industrial 24V 10A PSU like THIS and bolt it to the back of the monitor but for now I just needed 24V at 8A or more. Although I’m clearing out old PC bodging bits all the time I happened to still have a few ATX PSUs spare.

You might see -12V listed on some supplies and think that between that and the main 12V bus you’d have 24V. You might, but the -12V rail is rated for a few hundred mA at most. Good for opamp circuits maybe but not this. Its only used for the serial ports that should have about a +-12V swing although they rarely do, especially in laptops.

2x ATX PSU in series gives 24V at about 20A, more than enough. Its important to note that you can’t just wire them in series, there’ll be fireworks and tears before bedtime.

It only works if you isolate one of the supplies. I did that by opening it up, clipping the earth wire from the IEC mains socket, removing the PCB and checking the back of the board to spot where it uses one of the mounting screws as a ground connection. That connection needs to be broken, either by breaking the PCB track or by replacing the screw with a plastic standoff. You’ll know when you’ve done it correctly if you get no continuity between the black output ground wire and the case of the PSU or its mains earth pin.

To switch an ATX supply on the green wire on the main motherboard connector must be grounded (to its local ground, important for the isolated supply that floats 12V above the lower PSU’s ground). Once that was all done I connected the 12V output of the first, still grounded, PSU to the black ground wires of the second, isolated, PSU. 24V DC is then available between the first supply’s ground and the yellow 12V of the second supply.

At this point it was about 0100, I’d been home with the monitor since about 1900 although I did take an hour out for supper first – keep your blood sugar high when doing brain work boys and girls. It really does make a difference.

Faultfinding

Power polarity triple checked with a member of the clergy present, mothers number on speed dial,  Sonderausrüstung checked and at the ready, and suitable sacrifices prepared for the God of Magic Smoke

3, 2, 1 – GO!

Aaaaaaaand it turned off INSTANTLY. Took maybe 100mS? Power LED flickered blue for just a moment then went red.

Apparently for LCD monitors with CCFL backlights there is a common fault known as ‘2 seconds to black’. Its caused by either a blown CCFL tube or dodgy insulation or soldering at the tube ends. Less commonly caused by dodgy electrolytic or high voltage caps on the driver board. The inverter drive chip is paranoid and constantly checks for out of spec conditions on its outputs. If its unhappy about something it powers down after exactly 2 seconds. Clearly this is not that. I changed the 2 electrolytics on the inverter board anyway since they were noname types.

Invertor PCB

There were no burn marks, hot smells, cracked semiconductors or bulging caps or loose connectors. I checked the voltages on the main 24V bus and the outputs of the various voltage regulators scattered about the main board. The actual panel drive board here:

LVDS to Panel Board

I have no intention of messing with that. If its gone then its game over.

Rear Internals Overview

Crossover 30Q5 Pro Black 30 inch IPS Monitor Rear Overview

DigitalWave DW270QDP MP REV.02 DVI to LVDS Board PSU PINOUT MARKED

 

 

DigitalWave DW270QDP MP REV.02 DVI to LVDS Board

Annotated DVI to LVDS Board GAON GAON DigitalWave DW270QDP MP REV.02

The voltages on the main regulators are noted on the photo. There are 2 versions of the image, one with more obtrusive annotation. The 2 on the left side are AP1501, 3A 150kHz switchers. The upper one has a settable voltage for the panel. The correct feedback resistors are selected by the VCC_JUMPER. The upper right one is AP1084, a 1.8V LDO regulator. All voltages were fine, no particular ripple seen on the scope. Nothing getting too hot.

Fuck.

Repair

At this point it was about 0230 and I was fraying round the edges a bit, bargain of the century was looking like a bum deal.

Then as I was musing on the difficulty of desoldering large components when lead free solders involved I remembered an article I’d read a while ago about tin whiskers growing out of lead free joints and shorting out fine pitch chips.

LED-microscope-60x

I have a little LED microscope that hinges in the middle, £1 on ebay sort of thing. I got given one as a present and its been invaluable. Its amazingly good for what it is and I use it every day. After checking the solder round the large chip in the centre of the board I could see a bit of fuzzyness catching the light.

When something is knackered anyway you might as well have a go – you usually can’t make it much worse. With that in mind I got out my temp controlled hot air soldering gun. I masked off anything fragile with capton tape, wiped the lines of pins with flux and let rip. You can see the joints melt and reflow as the temperature comes up, going slow is best. After a couple of minutes I reckoned I’d got them all. I left it all in place to cool down then hooked it up.

VICTORY!

Really nice image quality, no dead or stuck pixels.

This is the first time I personally have come across tin whiskers as a fault. I regret not being able to take photos of the whiskers but I only have my phone camera. Although I know you can arse about with CD player lens to bodge something together by about 0300 I had no patience for it.

The next day I used a bit of thermal epoxy to stick some heatsinks to the larger regulators just in case. My workshop is on the top floor in an uninsulated room just in front of a window thats permanently open about 2″ to allow a network cable to scoot down the front of the house, into the cellar, then up into the sitting room and into the router. Heat should not be an issue…

Usually with fault finding about 90% of the time its power related, capacitors or moving stuff. When you’ve ruled those out it gets a lot tougher.

I was lucky with this one, if it had been a fault in the main chip I’d just have scrapped it and sold the panel – its the same panel as used in the Apple 30″ Cinema displays and possibly a Dell one too. As it stands tho its a worthy replacement for the 24″ CRT. I’m still holding onto the GDM-W900 for a while just in case this new one gives up the ghost. Hopefully if you’re trying to get one of these monitors going this page has been of some use.

There are some more photos that I need to upload, my phone is being stubborn and not letting me browse the camera directory from Windows 7, probably too many files. I’ll stick it into my laptop and clear it out when I can actually be arsed.

2017 Update:

Monitor is still working. I got a proper 24V ’10A’ PSU from Amazon for about £15 (personally I wouldn’t pull more than about 6-8A from it continuously).

The only downside is that I recently moved house (hence lack of new posts). Even tho the monitor was VERY well packed with blankets etc after I set it up in the new place I noticed a stuck blue pixel. Its in the lower 10% of the panel about 40% of the way from the right side. The Windows 7 taskbar covers it nicely, its only an issue when watching 16:9 aspect video due to this being a 16:10 monitor you will get small black bars at top & bottom. Its like the horizontal wires in Trinitron monitors; invisible till you notice them – then they might as well be glowing bright red. You’ll NEVER lose sight of them again.

 

 

Sony GDM-W900 24″ Widescreen CRT Monitor limps on

My beloved monitor for the last 7 or 8 years has been a CRT. But not just any CRT, its a Sony GDM-W900 in all its 24″ 16:10 1920×1200 glory. Inky dark blacks, amazingly vivid colours, endless odd resolutions, 5x BNC input as well as VGA. They cost thousands and were used for CAD, film grading, special effects houses, pro photographers, etc.

I was originally gifted mine in a broken state after repairing some guitar amps. As I was leaving he casually asked if I wanted it for parts. His house movers had dropped it down a flight of stairs (weighs 41kg/90lb!).  He’d had 3 on his desk…

The main damage was to the row of buttons at the front, PCB snapped off and missing etc. Luckily it used the IO line saving trick of using an ADC witha different valued resistor on each switch. I was able to work out the value progression and fill in the missing values and switches.

GDM-W900 Front

Switched it on with great caution after making sure the rattling bits in the case were just broken bits of casing, there were no other broken PCBS and the tube neck was intact.

Cue the loudest degaussing twang I’ve ever heard and it popped into life. It was out of focus and there was a huge green splodge in the lower right corner which wouldn’t degauss away. After literally a couple of hours exploring its menus and controls I managed to adjust the landing and convergence so it looked fantastic.

5 years of monitor heaven and and an expensive GPU later it started slowly drifting out of focus and would then make a loud snapping noise and pop back into focus. I thought, and was told by others, it was the flyback transformer insulation dying and turns shorting out.

In the end I had to find the focus pot on the flyback and drill a hole in 3 layers of casing (that lined up when reassembled: about as much fun as it sounds). After that a long Philips head screwdriver was permanently inserted and used to tweak the focus. Worked amazingly well. For another several years.

Flybacks Flyback in GDM-W900

GDM-W900 Top with focus adj

The last few months I’ve been expecting it to finally pop every morning when I switch it on or whenever the res change relays click. Its been bright green for an increasing amount of time after being switched on, a sharp tap on the screen with a wooden spoon often resolved it.

It still soldiers on, Sony made an amazingly good quality bit of kit, assuming you could afford to pay for it.

But I did start looking for another monitor. Replacement 24″ widescreen CRTs are very rare now (2015) and go for silly money. Thats assuming its within range. Not sure I’d trust any courier with one.

Main candidates were either HP LP2475W or similar. 24″ 16:10, IPS, wide gamut, composite & S-Video inputs as well as VGA and DVI etc. Found several for about £100 but then saw one of those 30″ Korean IPS screens listed as broken which I won for £5.

See HERE for how that turned out.

EDIT:

Here is the service manual for the GDM W900 and for the GDM FW900, should be helpful to anyone trying to keep one alive.

There is also a zipped driver for the W900, install the .inf and all the screen modes should show up in Windows. Also has lots of ICM profiles etc. Its not just for the W900, I think it covers most of the higher end Sony CRTs (and probably the rebadged SGI, HP etc versions too)..